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Working With Media and Creating Links

Part one: Working with Media

Description:

Images are one of the basic elements of almost every website that makes it more
interesting and interactive. You can insert any image from existing file into a web page,
as long as it is accessible to Dreamweaver and in a web format. Most images in web
pages are either GIFs or JPEGs.

After completing these activities you’ll be able to insert images to your document.

Activity 5.1: Adding images

1. Start Dreamweaver.

2. Create a new HTML document. = =S
& Ffe Bt Vew [t Modfy fomst Commands Sie !

3. Save and name the Dreamweaver e < arke
e = T
document as Lab5.html. T o T
4. Position the insertion point where you e 1
want to add an image. e Xy
Tabke Oliects '
5. Select Insert > Image (Figure 1). BEMES '
The Select Image Source dialog box Figure 1: Inserting Image

opens (Figure 2).
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11.
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13.

14.

15.

Browse to the folder with the desired
image.

Select the desired image.

Preview of the image appears in the
right side of the dialog box.

Click OK.

If the image is not in your site folder,
Dreamweaver asks if you want to copy
the file there (Figure 3).

Click Yes.

The Copy File As dialog box appears.
By default the image will be copied to
the root folder of your site. You can
store the image in the root folder, or
place the image in a subfolder of your
site.

Browse to a folder in your site where
you want to store the file, and click
Save (Figure 4).

The Image Tag Accessibility Attributes
dialog box opens (Figure 5). This
dialog box lets you add a description to
the image so that screen readers can
interpret it.

Enter a brief description. You can also
provide a link to a file with a longer
description.

Click OK.
The image is added to your document.
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Figure 2: Select image source dialog box

Dreamweaver, [gl

<P This File is outside of the root Folder of site 'MySite’,
\_T/ and may not be accessible when you publish the site,

Your rook Folder is:
CiDocuments and SettingstAdminiskratoriDeskboph iy webh

Would you like to copy the file there now?

[ Yes H Mo ][ Cancel ]

Figure 3: File outside of root folder warning message

Copy File As PIX
Savein: | E3 ] V| | T = E-
& | el html & |labzz html
& | &3 html Tst.css
& | ex3Format.heml st css
& | ex11.hkml & | Untitled-2. heml
& |lab1.hnl
& |labz. bl
File name: |Sunset.ipg | [ Save ]
Save as type: |AII Files [*.7) v| [ Cancel ]
Figure 4
Aberrte teot) | - \ k]
" Caum |
Long descrigbons  itp K/ - ——
wh |

¥ you don't waett tn erder thes réormstion when reartng
oliedts, Duoot the Acceasdidy b s{sterces

Figure 5: Image Tag Accessibility Attributes dialog box
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Activity 5.2: Resizing images

You can resize an image by clicking on it and dragging selection handles, or you can
change the width and height of the picture from the properties inspector.

1. Select the image you just added In juu5a
activity 5.1. -

2. Change the picture width and height
to 400 (Figure 6).

00V dgee  ood 8 Anoea ¥

Figure 6: Changing picture width and height.

Activity 5.3: Creating Rollover Images

A rollover is an image that changes when the pointer moves across it. A rollover actually
consists of two images: the primary image (the image displayed when the page first
loads) and the rollover image (the image that appears when the pointer moves over the
primary image).

Rollover images add highlighting or design effects by drawing viewer attention when the
images are swapped.

1. Start Dreamweaver. e —
Common ¥
2. Create a new HTML document. B Table -
3. Make sure the Common category is Insert Div Tag
selected in the Insert bar. Click the ;'Imagesﬂmage
2| Image

down arrow on the Images button and
select Rollover Image from the pop-up

=, Image Placeholder

menu (Figure 7) b B Fireworks HTML
:'L Mavigation Bar
. 17 Craw Rectangle Hotspot
The Insert Rollover Image dialog box O Draw Oval Hotspot —
Opens (Flgu re 8) . 7 Draw Polygon Hotspot

Figure 7: Images pop-up menu
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: e
4. Use the Insert Rollover Image dialog i e
box to set up your rollover: ST —
S magr i rr—
» Image Name: Type a name for the e
rollover image. e o —
« Original Image: Click Browse and

select the image to be diSplayed when  Figure 8: Insert Rollover Image dialog box

the page Ioads' for example Sunset- 7 Untitled Document - Windows Internet Explorer
from My Document & > £ COD00ments ol SettngsL Admnisty 3o De s oMy Weblab 5 hird
Fie B View Fovorkes  Togks  Heb

« Rollover Image: Click Browse and =~ "™ =~ H = 0 ks -y

. . & Urtttied Docurarne
select the image to be displayed when
the pointer rolls over the original
image, for example Winter.jpg from
My Document.

 Alternate Text: Type the text you
want to appear as alternate text for the
image.

* When Clicked, Go To URL: Click
Browse and select the file (or type the
path to the file) to be opened when the
image is clicked.

Figure 9: The original image

5. Click OK to close the dialog box.

Unmittted Docurment - Windaws lnternet [xplorer
B COADOCUTants arv Satmnge At Mor St oq My Wbl od

Phe Ik Vew  Poaorter  Tools  Meb

6. Save the page. ¢ reccrtae  2a Kl o i Nk e et e+
S Unened Dot
7. Select File > Preview In Browser and
select a browser from the submenu to
preview the rollover image.

Figure 10: The Rollover image
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Part Two: Creating links

Description:

There are several different types of links in Adobe Dreamweaver CS4:

* An internal link (document-relative pathname link or site-root-relative pathname link)
goes to another page in your site.

* An external link (absolute pathname link) goes to another site.
* A named anchor link goes to a specific position on a page in your site.

» An e-mail link opens a blank e-mail message window instead of linking to a page.

Activity 5.4: Creating an internal link

Start Dreamweaver. =3

SW o File  EBdit  Wiew Insert  Modify  Format  Cornr

2. Create a new HTML document.

links hkrnl* 3

.| Code ‘j i Esign ive View (w0
3. Save and name the Dreamweaver (IEF =R E LR | T
document as links.html. Go to |IELEENA

4. Write the following text into the
document “Go to Lab5.html”.

5. Select the text “Lab5.html” (Figure

Figure 11: The Selected text

Owm bovet [hvicw v | v BI EZUE 1w
11) &% D ore v w ¥ Taepet
6. Click HTML in the Property inspector EEmN e
(Figure 12) Figure 12: Text Property Inspector
7. Beside the Link text box in the _ﬂd
Property inspector (Figure 13), click " L.
the Browse for File (file folder) icon. T e =
8. The Select File dialog box opens &:iiii —Sic.
(Figure 13). e
9. Browse to the file “Lab5.html” that &
you created in previous activity and £~
click on it.
Forw -t l___
10 CIICk OK M Al v |
You will notice that “Lab5.html” e | (e
changed to the blue COIOr WIth s o ion om e mbven
underline.

11. Select File > Preview In Browser and Figure 13: select File dialog box
select a browser from the submenu to
preview your work.

Done by, Fatima Alhawaj Page 5



DW CS4-LAB5

MISA210

Activity 5.5: Creating an external link

1. Write the following text into the

document “Go to Google”.
2. Select the word “Google”.

3. In the Link text box in the Property
inspector, type or paste the address
(URL) of the site to which you want to
link (Figure 14).

Remember to include “http://” in the
address.

Note: If you want the link to open in a
new browser window, select the link
and use the Target pop-up menu in the
Property inspector to select “_blank.

4. Select File > Preview In Browser and
select a browser from the submenu to
preview your work.

(W ]4% O [100% 777 x 493+ 1K /1 sec

Class | | v B I

Link | http:fjvmw, google . com blanlk e

Figure 14: URL in Link text box

Targek

Activity 5.6: Creating a link to an e-mail address

You can add a link to an e-mail address. When visitors click the link, their default mail

applications will launch.

1. Click in the document where you want
the link to appear, or select the text or
image you want to format as the e-mail
link.

2. Do one of the following to insert the
link:

e Select Insert > Email Link (Figure
15).

e In the Common category of the
Insert bar, click the Insert Email
Link button.

Modify  Format  Commands — Site
1 Tag. Chrl+E Q
! Image Chrl+AlE+
1| Image Objects 3 Title
7 Media 3

Table ChrH-Alk+T

Tahle Objects 3

Layout Objects 4

Farm 3

Hyperlink,

Emnail Link.

Marned Anchor Chrl-Alk+A

Date

Server-Side Include

Comment

Figure 15: Insert Email Link
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3. The Email Link dialog box opens
(Figure 16).
Text: | Email me
4. In the Text box, enter text for the link. il | falhawaj@hotmal com CH_"JI

5. If you selected text to format as the

. . Figure 16: Email Link dialog box
link, that text appears in the Text box.

6. In the E-Mail text box, type the e-mail
address.

7. Click OK to close the Email
dialog box.

Link

8. Select File > Preview In Browser and
select a browser from the submenu to
preview your work.

Activity 5.7: Creating a link to a named anchor

To link to a specific location on a web page, first create a named anchor at that location,
and then link to the named anchor.

| e | e e Ml ||t L s M & B

1. Assume you have the
document as shown in (Figure
17) and when you scroll down
you will find more information

A snantplone, o st plosie, a i mobae phome et an i mobile opecatig
yete, with more
tentmre phone

wlvineed computing copabulsty and conpectivaty thoan a

Opernting Svstems:

about the other operating
system types.

Scroll down and Position the
insertion point at the location
“Windows Phone”.

3. Select Insert > Named Anchor.

The Named Anchor dialog box
opens (Figure 18).

Done by, Fatima Alhawaj

1 Android

2 108

LV Windows Phone
o Blackberry

Androld

Android woan openssongeeplattonn tosmdod m Oxtober 2005 by Andy Ruba
uml backed by Google, nlong with mujor husdwure and soltwine developer
conch o latel, HTC, ARM, Motatola and Samsnng

108,

Tor YT S ende B ambrndiemed thin rrmnal (Pluewien e ol s et sndule
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Figure 17
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4. Enter the name “Windows” and
click OK.

Named Anchor

anchor name: | windows “

Cancel
5. Select the text “Windows Phone” to |
link to the named anchor.

Figure 18: Named Anchor dialog box

6. In the Link text box in the Property
inspector, type “#” and then type or
paste the anchor name (Figure 19).

7. Select File > Preview In Browser
and select a browser from the Figure19
submenu to preview your work.

Activity 5.7: Creating Image Maps

An image map is an image that has been divided into regions, or hotspots. When a visitor
clicks a hotspot on your web page, an action occurs; for example, another web page
opens. An example is a geographic map that links each country in the map to another
page in your site or an external website containing information about that country.

Tor e T\

1. Start Dreamweaver.
2. Create a new HTML document.

3. Save and name the Dreamweaver
document as imagemap.html.

4. Position the insertion point where you
want to add an image.

Select Insert > Image.

Browse to the folder with the desired
image.

7. Select the desired image, “in this

example Middle East Map” (Figure
20). Figure 20: Middle East Map
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8.

10.

11.

12.

Select the image in the Document
window. In the Property inspector,
type a name for the map in the Map
text box (Figure 21).

Select one of the hotspot tools located
below the Map name, and draw a
rectangle, circle, or polygon around a
part of the image in this example
around “Bahrain” (Figure 22).

As soon as you begin drawing, you are
prompted to enter an Alt tag for the
hotspot.

Click OK, enter a descriptive name in
the Alt text box in the Property
inspector, and then finish drawing the
hotspot.

After drawing your hotspot, add a link
to a page in your site or to an external
URL (Figure 23), in this example add
the link http://www.bahrain.bh

Select File > Preview In Browser and
select a browser from the submenu to
preview your work.

MISA210

Map | middle| \ Space Target
|£| | D r“-?ij H Space Driginal

Figure 21: Adding map name

Map | middle| Y Space Target
|£| 00O %) Hspace 2riginal

Hotspot tools

Figure 22: Hotspot Tools

PROPERTIES | ¥ALIDATION | BROWSER COMPATIEBILITY | LINK CHECKER

E'Oﬁ]l Hotspok Link | http: v bahrain.bh {3@

Target ¥

Map

A OOW
Figure 23: Hotspot Property Inspector
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In-Class Exercise:

1. Start Dreamweaver

5 Unritied Decusert

2. Click HTML to create a new document
Welcome to University of Bahrain

3. Create two web pages as follow: i\
76

Pagel.: Y u;
e When you click on the title e

Send me an ¢-mal

“Welcome to  University of

Bahrain” the UOB  website page1

http://www.uob.edu.bh will open in

* I o Dot B e tooswd

new blank page.

e When you click on the UOB logo it
will go to Page2.

e When you click on “send me an e-
mail” it will send an e-mail to
uob@uob.edu.bh.

Page 2:
e Includes a rollover image, Page 2

choose any two images Yyou
want about UOB.
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